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Summary

The Gerber Setup Dialog

When generating
Gerber File output,
configuration of output
options prior to
generation is performed
using the Gerber Setup
dialog.

General Tab

Use this tab to specify the units and format to
be used in the Gerber output files. The units
can be either inches or millimeters.

The format specifies the precision of the
coordinate data, which must be selected to
suit the placement precision of the objects in
the PCB workspace. For example, the 2:3
format has a resolution of 1mil (1/1000 inch).
If your design has objects placed on a sub-
1mil grid then this format will not be
adequate. Conversely, the higher precision
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The Gerber Setup dialog provides you with tools to completely configure your Gerber file
output options. This dialog is divided into the following tabs:

Specify the units and format to be used in the output files.
This contrals the units [inches or milimeters), and the number of digits before and after the
decimal paint.

Units Forrmat
(@) Inches ®23
O Millimeters O z4

Q25

The number format should be set ta zuit the requirements of wour Praject.

The 2:3 format haz & 1 mil resolution, 2:4 has a 0.1 mil rezolution, and 2:5 has a 0.07 mil
resolution.

If wou are uging one of the higher resolutions vou should check that the PCE manufacturer
supports that farmat.

The 2:4 and 2:5 formats anly need to be chozen if there are objects on a grid finer than 1
mil.

formats may be more difficult and expensive

to photoplot and manufacture.

Layers Tab

Use this tab to enable each layer that you want
to generate a Gerber file for. You can also
specify, for each layer, whether a mirrored
Gerber file is to be created.

You can also nominate which mechanical
layer(s) are to be added to all Gerber plots.

When generating Gerber output from a PCB
design that contains embedded board arrays or
is panelized (shown in Figure 1), the design is
analyzed automatically for layer stackup
violations.

e Embedded boards that are flipped will display
their layer stacks as flipped.

e Mid signal layers and internal planes that are
different can still appear on the same mid
layer panel.

e Mid signal layers and internal planes can be
flipped against each other.
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| General | Layers | Diill Drawing | Apertures | Advanced

Layers To Plat Mechanical Layers(s) to Add ta A

Extension | Design A Design & [Flipped)] Dresign B Plat | Miror | | Layer Mame Plot

] Top Overlay Bottom Overlay Top Overlay techanical 1
Top Paste Baottom Paste Top Paste

GTS Top Solder Mask Bottom Solder Mask. Top Solder Mask

GTL Top Layer Bottom Layer Top Laper

GF1 IrternalFlanel bdidLayer] IntemalFlane

Gl tidLayer] InternalFlane1 fidLaper]

GFZ e IntemalFlane2

G2 MidLapers

G3 MidLaperd

Gd e e tdidLaperd

GEL Biottam Laper Top Layer Bottom Layer

GES Bottom Solder Mask  Top Solder Mask Bottom Solder Mask

GBF Bottomn Paste Tap Paste Battom Faste

GBD Bottam Overay Top Overlay Bottom Overlay

GKOD Keep-Out Layer Keep-Out Layer Keep-Out Layer

GM1 Mecharical 1 Mechanical 1 Mechanical 1

GPT Top Pad Master Bottom Pad Master Top Pad Master

GFB Boattomn Pad Master Top Pad Master Battorn Fad Master

[ Inchude unconnected mid-aper pads

Flot Layers = Mirror Lapers =

Figure 1.The Layers tab displays layer stackups for embedded board arrays
(panelization). Notice here that any compatibility violations display in red.
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Drill Drawing Tab

Use this tab to specify which layer-pairs a drill
drawing is required for (mirrored output files can
also be generated). You can also specify the
type and size of drawing symbol to be used to
represent the various drill sizes.

Use this tab also, to specify which layer-pairs a
drill guide file is required for (mirrored output files
can also be generated). The drill guide is a plot
of the location of each drill site on the PCB, with
each site marked with a small cross.

Apertures Tab

Use this tab to enable/setup the required
aperture information for the design.

When you enable the Embedded apertures
(RS274X) option, the aperture list is created
automatically, each time you generate the
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General | Layers | Dill Drawing | Apertures | Advanced
[orill Drawing Plots
[ Plat all used laper pairs [¥] Mirrar plats Diill Drawing Spmbols
Top LayerBottam Layer (®) Graphic symbals
() Sige of hole sting
() Characters
Symbol size
Drrill Guide: Plats
[C]Plat all used layer pairs

Gerber files. The apertures are then embedded in the Gerber files, according to the RS274X standard. This feature means that

you do not need to worry about whether the
current aperture list includes all the required
apertures.

If you do not enable this option, the main
apertures region of the tab becomes enabled,
from where you can load, create, edit and save
an aperture table exactly as you require.

D010 Round MULTIFLE ]
D011 Round MULTIPLE X5Y:5H:0 3
D012 Round MULTIPLE <EY:6H:0

D013 Round MULTIPLE X7 %:7 H:0

D014 Round MULTIPLE #7.2%:7.2 H:0

D015 Round MULTIPLE :7.333Y:7.333 H:0

D016 Round MULTIPLE #:8Y:8H:0
D017 Round MULTIPLE %:9Y:9H:0
D018 Round MULTIPLE :10%:10H:
D019 Round MULTIPLE #12%:12H
D020 Round MULTIPLE #18%:18H
D021 Round MULTIPLE :20%:20H
D022 Round FLASHOMLY ;32 .32
D023 Round FLASHOMLY »: 4040
D024 Round FLASHOMLY »:48 Y48 H:
D025 Round FLASHOMLY =:50%.50 H:0 W
D026 Round FLASHOMLY »:50 Y300 H:0

D027 Round FLASHOMLY *:58 .58 H:0

D028 Round FLASHOMLY »:58 Y308 H:0

D029 Round FLASHOMLY ;62 .62 H:0

D030 Round FLASHOMLY »: 7070 H:0

D031 Round FLASHOMLY *: 7272 H:0

D032 Round FLASHOMLY *:125Y:125 H:0

D033 Round FLASHOMLY ;140 ;140 H:0 b

[ Mew... ” Edi... ”Bename...” Delete ]
[

H:0
H:0
0

Lreate List From PCB | [Lgad... ] [Sage...] [Elgar...]

When creating new apertures, the DCode dialog
appears. You can define up to a maximum of
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General | Layers | Diill Drawing |Aparluras |Advanced

Embedded apertures [R5 274x)

Options

M arimum aperture size
Generate relief shapes
Flash pad shapes

[ Flach all fill:

D Apertures List
DCode | Shape Usage
Dm0 Round MULTIPLE

# Size ¥ Siwe  Hole Size | % Offset |Y Offset |
e B kI il il [d

=

e ] [ Edit... ] [ Hename... ]

[ Delete

:
[

Create List From PCE

] [Ceai.] [5ae.

[ o

H Cancel l

1000 different draft codes, in the range D00-D9999, although some of these codes (usually
D00-D09) may be "reserved" when targeting some plotters, so use of these codes is not
generally recommended. Do not include the "D" in any new draft code you enter.

After entering a new code, you will be transferred to edit mode and the Aperture dialog will

appear, from where you can edit the properties of the aperture as required.

Any changes made are applied to the aperture file currently loaded into memory. These
changes do not become permanent until you use the Save button (on the Apertures tab of

the Gerber Setup dialog).

Aperture
F‘ropertias‘
ReliefEnties 2 O 4 @&
[ 0K H Help ]
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Advanced Tab

Gerber Setup

General || Layers | Drill Drawing || Apertures |

Filmn Size:
¥ (honizontal) | 20000mil
' [vertical) 16000mil

Border size 1000wl

Aperture bMatching Tolerances

Plus 0.00Gril
Minus 0.005mil

Batch Mode
() Separate file per laper
() Panelize layers

Other

[] G54 on aperture change

[]Use software arcs

Leading/Trailing Zeroes
() Keep leading and traling zeres
(%) Suppress leading zeroes

() Suppress bailing zeres

Position o Film
) Reference to absolute origin
(%) Reference ta relative origin

() Certer an film

Flotter Type
() Unaarted [raster]
) Sarted [vectar)

Optimize change location commands
[¥] Generate DR Rules export file [RUL)

Use this tab to specify options such as the
virtual film size to be used during Gerber
generation, aperture matching tolerances and
the use of zero suppression.

The Gerber data can be automatically
centered on the specified film by enabling the
Center on film option.

Use this tab to also specify the type of output
plotter to be used - either vector or raster.
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The following table lists each of the Gerber files that can possibly be generated as output from a PCB document. In each case,
the Gerber file is generated with the same name as the PCB document (i.e. PCBDesignName.GerberExtension).

Gerber Extension Description

G1, G2, etc Mid-layer 1, 2, etc

GBL Bottom Layer

GBO Bottom Overlay

GBP Bottom Paste Mask

GBS Bottom Solder Mask

GD1, GD2, etc Drill Drawing (assignment based on order of drill pairs appearing in the Drill-Pair Manager dialog)
GG1, GG2, etc Drill Guide (assignment based on order of drill pairs appearing in the Drill-Pair Manager dialog)
GKO Keep Out Layer

GM1, GM2, etc Mechanical Layer 1, 2, etc

GP1, GP2, etc Internal Plane Layer 1, 2, etc

GPB Pad Master Bottom

GPT Pad Master Top

GTL Top Layer

GTO Top Overlay

GTP Top Paste Mask

GTS Top Solder Mask

P01, P02, etc Gerber Panels

APR Aperture File (generated when embedded apertures (RS274X) are used)

APT Aperture File (generated when embedded apertures (RS274X) are not used)

In addition, the following files are also generated:

o PCBDesignName.rul — this file contains all design rules defined for the source PCB document from which the Gerber data
is being generated. This file is generated provided that the Generate DRC Rules export file (.RUL) option is enabled on the
Advanced tab of the Gerber Setup dialog.

o PCBDesignName.rep - this file provides a generation report, showing which Gerber files have been generated.

When embedded apertures (RS274X) are not used, a separate text-based aperture file will be generated for each generated
Gerber layer - for example, GBL will have an associated aperture file with extension ABL. Each of these files is identical in its
content. The true Gerber aperture file is distinguished by its .apt extension in this case.

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click the '?' button
at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

Gerber output can be generated in one of two ways:
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e Using an appropriately configured output generator defined in an Output Job Configuration file (* . OutJob). Output will be
generated upon running the configured output generator

o Directly from within the active PCB document using the File » Fabrication Outputs » Gerber Files menu command. Output
will be generated immediately upon clicking OK in the Gerber Setup dialog.

Note: The settings defined in the Gerber Setup dialog when generating output directly from the PCB are distinct and separate to
those defined for the same output type in an Output Job Configuration file. In the case of the former, the settings are stored in
the project file, whereas for the latter they are stored in the Output Job Configuration file.

When generating Gerber output, you can specify that the output be opened automatically in a new CAM document. The way in
which this is accomplished depends on how you are generating the output:

e From an Output Job Configuration file - enable the Gerber Output auto-load option in the Output Job Options dialog (Tools
» Output Job Options from the OutputJob Editor)

e Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Options
For Project dialog (Project » Project Options).

Unless your PCB manufacturer does not support embedded apertures it is highly recommended that you use the Embedded
apertures (RS274X) option. Most modern photoplotters are raster plotters which can accept any size aperture. Generally, they
also accept Gerber files with embedded apertures.

If your manufacturer doesn't use embedded apertures, a separate aperture file (* . apt) should be included with the Gerber files.

A special aperture must be provided for any file when holes are defined for any pads or vias in the PCB file. This is because the
PCB Editor needs to provide an aperture for stroking Drill Drawing symbols and/or text. The aperture is required even if you are
not generating a Drill Drawing plot. If no holes are in the file (eg. no vias, all pad holes defined as 0), the aperture is not
required.

When you use an existing aperture file, the PCB Editor scans the primitives (tracks, pads, etc) in the PCB document and
matches these with aperture descriptions in the loaded * . apt file. If there is no exact match of aperture to primitive, the PCB
Editor will automatically "paint" the primitive with a suitable smaller aperture. If there is no aperture suitable to "paint" with, a
*  MAT (match) file will be generated listing the missing apertures and Gerber file generation will be aborted.

If using automatic aperture generation the required apertures for Drill Drawing symbols and other text is automatically provided
with the stroke width being proportional to the text height. For example, the default 50 mil Drill Drawing symbol size yields a 7mil
aperture for stroking the symbols. 60 mil text height yields 8 mils stroke width. You should take care in defining text sizes for
Silkscreen (or Overlay) layers, as very fine strokes may not be successfully screened onto the board.

The Gerber file extension naming convention conforms to general industry practice.

Check with your manufacturer to see if they can accept PCB files directly. Many manufacturers will be able to produce a PCB
directly from a binary PCB file.

Contact your photoplot bureau before generating any photoplots. Matching available plotting options at the edit level can save
considerable time and expense when generating Gerber phototools.

The output path for generated files is set in the Options tab of the Options for Project dialog. By default, the output path is set to
a sub-folder under the folder that contains the Project file and has the name: Project Outputs for ProjectName. The output
path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options
tab, then the Gerber files will be written to a further sub-folder, named: Gerber Output.
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When generated, the output will be added to the project and appear in the Projects panel under the Generated folder, in an
appropriately-named sub-folder. If you have used a separate folder for each output type, then corresponding (separate)

Generated folders will be added to the Projects panel (e.g. Generated (Gerber Output)).

Date Version No. Revision

05-Dec-2005 1.0 New release

12-Apr-2007 1.1 Updated for Altium Designer 6.7
4-Mar-2008 1.2 Updated Page Size to A4.
26-Mar-2008 1.3 Minor update.

27-Jul-2011 - Updated template.
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