This Application Note provides a general overview of design object placement and editing methods used in the Schematic Editor. Detailed explanations of placing and editing some of the more complex objects, such as wires and parts are also included.

**Fundamentals of Object Placement**

**Grids and Cursors**

Before placing objects in the Schematic Editor, set the grids to enable easier placement. Altium offers three grid types: visible grids for navigation; snap grids for placement and electrical grids for aiding the creation of connections. Grids are document options, meaning that they are saved with the individual design, so grid settings may differ between one design document and the next. Set your grids initially in the Document Options dialog (Design » Document Options).

Visible grids appear whenever the zoom level will allow them to be sufficiently spaced, displayed as either lines or dots. The Snap grid is the grid that the cursor is locked to when placing or moving schematic design objects. Overriding Snap grids are Electrical grids, which allow connections to be made to off-grid parts. When moving an electrical object in the workspace and it falls within the electrical grid range of another electrical object that you could connect to, it will snap to the fixed object and a hotspot (red cross) will appear. The Electrical grid should be set slightly lower than the current Snap grid or else it becomes difficult to position electrical objects one snap grid apart.

Grids can be quickly modified or toggled between enabled and disabled, through keyboard or mouse shortcuts, for example, press G to cycle through the Snap grid settings of 1, 5 and 10. You can also use the View » Grids sub menu or the Grids right-click menu. Use the Grids tab under the Schematic folder in the Preferences dialog (Tools » Schematic Preferences or shortcut T, P) to set Imperial and Metric grid presets.

You can also change the Cursor type to suit your needs in the Cursor section of the Graphical Editing tab under the Schematic folder in the Preferences dialog. For example, a large 90 degree cross that extends to the edges of the design window (Large Cursor 90 option) can be handy when placing and aligning design objects.

**Placing Design Objects**

The basic steps for placing schematic design objects are outlined below.

1. Select the object type that you want to place. You can do this by selecting an object type from the Place menu (e.g. Place » Wire) or by clicking on one of icons on the placement toolbars. Shortcut keys for placement are also available (e.g. P, W to place a wire). To place components (parts), you can also click the Place button in the Library panel, or select the component name from an available library in the Library panel and drag it into the document.

2. When an object is selected for placement, the cursor will change to a crosshair, indicating that you are in editing mode, and, if relevant, the object will appear "floating" under the cursor.

3. Press the TAB key to edit the properties of the object before placing it. This will open the Properties dialog for the particular object, allowing you to change various options.
Once you have finished setting the properties, click **OK** to return to placement mode.

The advantages of editing during placement are that objects that have a numeric identifier, such as a designator, will auto-increment. In addition, changes made during placement can become the defaults for that type of object. Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option on the **Default Primitives** tab under the **Schematic** folder in the **Preferences** dialog (T, P) is enabled.

4. Position the cursor and left-click, or press **ENTER**, to place the object. For complex objects, such as wires or polygons, you must continue the position-and-click procedure to place all vertices of the object.

Note: If autopanning is active, you can move around the document by moving the cursor past the edge of the editing window in the direction that you wish to go. You can set the style and speed of autopanning in the **Graphical Editing** tab under the **Schematic** folder in the **Preferences** dialog.

The **AutoFocus** options in the **AutoFocus** tab under the **Schematic** folder in the **Preferences** dialog control the state of the schematic display, e.g. it can be configured to automatically zoom in when placing or editing connected objects or dim all wiring not related to the wire currently being placed.

Other zooming and panning options are available using the shortcut keys or mouse wheel. Use **Ctrl** key and scroll the wheel mouse to zoom in and out, push the wheel button down and move mouse up to zoom in or move mouse down to zoom out when placing. You can setup the behavior of your mouse in the **Mouse Configuration** tab under the **Schematic** folder in the **Preferences** dialog.

5. After placing an object you will remain in placement mode (indicated by the crosshair cursor), allowing you to place another object of the same type immediately.

6. To end placement mode, right-click or press the **ESC** key. In some cases such as placing a polygon, you may need to do this twice; once to finish placing the object and once to exit placement mode. When you exit placement mode, the cursor will return to its default shape.

For more information about specific design objects press **F1** when the cursor is over an object in the Schematic Editor, information about the object will appear in the **Knowledge Center** panel.

**Re-Entrant Editing**

The Schematic Editor includes a powerful feature called re-entrant editing which allows you to perform a second operation using the keyboard shortcuts without having to quit from the operation you are currently carrying out. For example, pressing the **SPACEBAR** when placing a part will rotate the object but will not disrupt the placement process. Once you place the part, another part will appear ready upon your cursor, already rotated.

Another example of when re-entrant editing is very useful is if you start placing a wire that it needs to be connected to a port which you have not placed yet. There is no need to exit Place Wire mode; just press the Place Port shortcut keys (P, R), place the port, press **Esc** to exit Place Port mode and then connect the wire to the port.
Measuring the Distance on a Schematic Document

The Schematic Editor has a distance tool located in the Reports menu (Reports » Measure Distance as well as the Ctrl+M shortcut keys). You can use this tool to measure the distance between two points on a schematic document. When you invoke this command, you are prompted to click on two points on the schematic document and once you have chosen two points, an Information dialog appears with an overall Distance value, with the X Distance and Y Distance values displayed accurate to two decimal places.

The measurement units are determined by the System Units chosen for the schematic document (Design » Document Options). If the dialog does not include measurement units, it means that the document is currently set to use DXP default units, where 1 unit is 10 mils. You can switch to Imperial or Metric units by toggling the System units (View » Toggle Units).

Placing Graphical Objects

Schematic objects are divided into two groups: graphical and electrical.

To place graphical objects, such as lines, arcs and text, use the Drawing Tools toolbar (available from the Utilities toolbar (View » Toolbars » Utilities). Drawing toolbar functions can also be accessed through the Place » Drawing Tools menu, except for Paste Array (Edit » Paste Array).

Placing Electrical Objects

Schematic electrical design objects define the physical circuit you are capturing. Electrical objects include components (parts) and connective elements, such as wires, buses and ports. Use the Place menu or the Wiring toolbar (View » Toolbars » Wiring) to place electrical objects.

The following sections detail the placement of two commonly used object types – parts (components) and wires.

Placing Parts

When Place » Part (P, P) is selected or you click on in the Wiring toolbar, the Place Part dialog is displayed. You can enter the name of the component in the Lib Ref field or you can click on the Browse button (…) to locate the part by searching for and adding the required library. You can find previously placed parts by clicking on the History button.
Parts can also be placed using the **Place** button in the Library panel or the Schematic Library Editor. Alternatively, select a component name in the **Libraries** panel and drag it into the document where it will appear floating on the cursor ready for placement. Click to place.

When placing parts, use a snap grid that will cause the pin ends to fall on a grid point, e.g. 10. Remember that you can press **G** to cycle through the Snap grid settings of 1, 5 and 10.

### Placing Wires

Wires are used to represent an electrical connection between points. When placing wires, be careful to use the **Place » Wire** command and not use the **Line** command by mistake. The Place Wire command is also available from the right-click menu when you are in a schematic document or the **Wiring** toolbar.

A wire end must fall on the connection point of an electrical object to be connected to it, e.g. the end of a wire must fall on the hot end of a pin to connect. As you are placing a wire, when the wire falls within the electrical grid range of another electrical object, the cursor will snap to the fixed object and a ‘hot spot’ (red cross) will appear. This hot spot guides you to where a valid connection can be made and automatically snaps the cursor to electrical connection points. The wire will be automatically terminated when it finishes on a hot spot.

It is recommended that you set the electrical grid to be slightly smaller than the current Snap grid, or it becomes difficult to position electrical objects one snap grid apart.

If you wish to place a wire that does not yet connect to another electrical object, right-click (or press **ESC**) to terminate the wire. Right-click, or press **ESC**, to exit wire placement mode.

While placing wires, use the **BACKSPACE** key to delete the last vertex placed.

### Wire Placement Modes

When placing a wire, press **SHIFT+SPACEBAR** to cycle through the wire placement modes. Various placement modes are available:

- **90 Degree**
- **45 Degree**
- **Any Angle**
- **Auto Wire**.

The mode specifies how corners are created when placing wires and the angles at which wires can be placed. Press **SPACEBAR** to toggle between the Start and End sub-modes (when in 90 Degree or 45 Degree modes), or between Any Angle and Auto Wire modes (when either of these modes is active).

The Auto Wire mode is a special mode that allows you to automatically connect two points on the schematic, automatically routing the wire around obstacles. When in this mode, press the **TAB** key to set the Autowirer options in the **Point to Point Router Options** dialog.

### Junctions

Wires have the Auto Junction feature, which automatically inserts a Junction object (dot) if a wire starts or ends on another wire or runs across a pin. The display, junction size and color of auto-junctions and manual junctions can be controlled from the **Compiler tab** under the **Schematic** folder of the **Preferences** dialog. You can also set wire cross-overs and convert existing wires to cross-overs using options in the **General** tab under the **Schematic** folder of the **Preferences** dialog.

See *Editing Placed Wires* later in this Application Note, for tips on how to modify a placed wire.
Editing Schematic Design Objects

Any design objects you have placed in a schematic can be modified in a variety of ways. Objects can be moved around within the document and cut, copied and pasted within and between documents. You can also edit the properties of objects to change their colors, designator, net assignment, etc. With some objects such as polyline shapes (for example buses, wires, polygons and lines), you can graphically change the shape of the object after it has been placed.

You can change just one object, or extend changes across your entire design using powerful editing options, such as queries. Several other useful tools will help you work with groups of objects at a time, including the Find Similar Objects dialog, the SCH List panel and the SCH Inspector panel.

See the Editing Multiple Objects tutorial for more information.

Placed components (parts) and footprints can be edited through their properties’ dialogs or changed in their Library Editors and updated. Pins can be edited by using the Component Pin Editor, available from the schematic Component Properties dialog (Edit Pins button).

Refer to the Creating Library Components tutorial for more information about creating or editing parts and footprints using the Library Editors.

Graphically Editing Placed Objects

It is generally easier to edit the look of an object in the workspace graphically. To do this, you must first select the object(s). When an object is selected, you can move the object or edit its graphical characteristics. Click on an object to select it and its ‘handles’ or vertices are displayed. To graphically change a selected object, click and hold on an editing handle. That point of the object will then become attached to the cursor, so simply move the mouse to a new location and release to resize. Click anywhere on a selected object to move it, or press the Delete key to delete it.

Editing Placed Wires

There are several ways you can change a placed wire — by moving a vertex, moving a segment, moving the entire wire or extending the wire to a new location. You can also edit, add or remove vertices through the Vertices tab in the wire’s Properties dialog. See the Editing Vertices from the Properties Dialog section for more information.

Editing by Moving a Wire’s Vertex

To edit a selected wire by moving a vertex, click on the wire to select it. Position the cursor on the vertex you want to move until the cursor changes to a double arrow. Then click and drag the vertex to its new location, as shown below.

Moving a Wire Segment

You can edit a selected wire by moving a segment of the wire. Select the wire and move the cursor over the segment until it changes to a ‘quad’ arrow. Then click and drag the segment to its new location, as shown below.

Moving an Entire Wire

To move the entire wire without modifying it, you do not have to select it first — simply click and drag.
Extending a Wire to a New Location

Placed wires can be extended or added to. Select the wire and position the cursor on the end you want to move until the cursor changes to a double arrow. Click on the endpoint and drag the ‘look ahead’ segment to the new location and click to place. You can change the placement mode while moving the cursor to the new location by using \texttt{SHIFT+SPACEBAR}.

To make a wire longer by extending it in the same direction, hold down the \texttt{ALT} key as you drag the selected endpoint.

Breaking Wires

Use the Edit » Break Wire command to break the wire segment into two pieces. This command is also available from the right-click menu when the cursor is over a wire. A ‘cutter box’ displays (by default) which is placed on the wire to be cut. The section to be cut out is masked as shown. The cutting length is the space between the two new segments. Press \texttt{SPACEBAR} to cycle through the three cutting length modes (snap to segment, snap grid size multiple or fixed length). Press \texttt{TAB} to set the fixed cutting length and any other cutter options. Click to break the wire. Right-click, or press \texttt{ESC}, to exit break wire mode. Break Wire options can also be set in the Break Wire tab of the Schematic folder in the Preferences dialog.

Note that you can also set the Components Cut Wires option in the General tab under the Schematic folder in the Preferences dialog. When this option and the Optimize Wires and Buses option are enabled, you can place a component onto a wire and the wire is cut into two segments which are automatically terminated onto any two ‘hot’ pins in the component.

Multi-Wire

The multi-wire editing mode in the Schematic Editor allows you to extend multiple wires at the same time. If multiple parallel wires share a coordinate for their end vertex, then when you click and drag to move the end of one wire vertex the end vertex of all other selected wires will also move, keeping the wire ends aligned.

Moving and Dragging Schematic Objects

To move an object in Altium Designer is to reposition it without regard to objects in contact with it. Moving a component, for example, will not move any of the wires connected to it. Dragging the component, on the other hand, stretches the wires out after it, maintaining connectivity. If you always want electrical wiring to stay connected when moving selected objects, enable the Always Drag option in the Graphical Editing tab under the Schematic folder in the Preferences dialog.

Moving Objects

You can move single, non-selected objects or multiple, selected objects, using the mouse to click-and-drag. You could also use the Edit » Move commands, especially if you wish to move the objects to the front or back of other placed objects.

You do not need to select objects first to move them around the sheet. Click and hold until the electrical hotspot markers appear and drag the component/object to the new location. The cursor will move to the nearest electrical hotspot, e.g. the pin closest to the cursor position when you first clicked on the object. The Object’s Electrical Hot Spot option (default) or Center of Object option in the Graphical Editing tab under the Schematic folder in the Preferences dialog will determine where the object is held during moving or dragging.

While objects are being moved:

- Press \texttt{SPACEBAR} to rotate the object. Rotation is anti-clockwise and in steps of 90°. Press \texttt{SHIFT+SPACEBAR} to rotate the object clockwise
- Press the \texttt{X} or \texttt{Y} keys to flip the object along the X-axis or Y-axis respectively
• Hold down the **ALT** key to constrain the direction of movement to the horizontal or vertical axis.

**Moving Selected Objects**

You can move selected objects using a combination of the Ctrl key and arrow keys (vertically or horizontally) or the Ctrl and Shift keys and arrow keys on the Schematic Document.

The movement of selected objects is set according to the current **Snap Grid** setting in the **Document Options** dialog (Document » Options or short cut D, O). Use this dialog to change the Snap Grid Value. This Grid value also appears on the Status bar of Altium Designer. The **Grids** tab under the **Schematic** folder in the **Preferences** dialog can also be used to set Imperial and Metric grid presets. Use the **View » Grids** submenu or the **Grids** right-click menu.

- Selected objects can be 'nudged' by small amounts (according to the current snap grid value) by pressing the arrow keys while holding down the Ctrl key
- Selected objects can also be 'nudged' by large amounts (snap grid value by a factor of 10) by pressing the arrow keys while holding down the Ctrl and Shift keys together.

**Dragging Objects**

The **Edit » Move » Drag** command enables you to move any object, e.g. a component (part), port, wire or bus, and any connected wires are moved with the object being dragged so that the connectivity of the schematic is maintained. The cursor changes to a crosshair, which you position over an object you want to drag, then click or press **ENTER**. Move the object to the required position and click, or press **ENTER**, to place. Continue moving other objects, or right-click or press **ESC** to exit dragging mode.

To drag multiple selected objects and maintain connectivity, use the **Edit » Move » Drag Selection** command.

Alternatively, you can drag objects using a shortcut key. Hold the **CTRL** key as you click, hold and move the mouse. You can then release the **CTRL** key once you start dragging. This also works with multiple, selected objects. Note that using the **CTRL** key temporarily toggles the setting of the **Always Drag** option set in the **Preferences** dialog.

While dragging the object:

- Press the **SPACEBAR** or **SHIFT+SPACEBAR** while dragging to change the wiring mode
- Press **CTRL+SPACEBAR** while in movement mode to rotate the object. Rotation is anti-clockwise and in steps of 90°.
- Press the **X** or **Y** keys while in movement mode to flip the object along the X-axis or Y-axis respectively
- Press **SPACEBAR** while moving to toggle the orthogonal wire mode for any wires connected to the object
- Press the **ALT** key while moving, to constrain the direction of movement to the horizontal or vertical axis, depending on the initial direction of movement.

**Locking Objects from Moving**

To prevent schematic objects from being moved inadvertently, you can enable the **Locked** property for these objects to protect them from being edited graphically. If you try to edit a locked design object, you will be prompted with a **Confirm** dialog and then you will be asked if you wish to go ahead with the action.

Note, if the **Protect Locked Objects** option is enabled in the **General** tab under the **Schematic** folder in the **Preferences** dialog and the **Locked** option for this design object is enabled, this object cannot be moved without prompting you for further action. When you attempt to select a group of objects including locked objects, the locked objects will not be selected.

**Using Copy and Paste**

In the Schematic Editor, you can copy and paste objects within or between Schematic Documents, e.g. component(s) from a schematic can be copied into another Schematic Document. You can copy objects to the Windows clipboard and paste them into other documents. Text can be copied from the Windows clipboard into a schematic text frame. You can also directly copy/paste a table-type selection from another application such as Microsoft Excel, or from any grid style control within Altium Designer. More advanced copy/paste actions can be performed using the Smart Paste feature.

Select the object(s) you want to copy, select **Edit » Copy (Ctrl+C)** and click to set a copy reference point on the object which will be used to accurately position the object during pasting. Note that you will only be prompted to click to set a reference point if the **Clipboard Reference** option is enabled in the **Graphical Editing** tab under the **Schematic** folder in the **Preferences** dialog.
Using Smart Paste

The Schematic Editor’s Smart Paste feature allows you to transform the copy of the selected objects into other objects as you paste them. For example, you could copy a selection of Net Labels and Smart Paste them as Ports, or alternatively you can select Sheet Entries and paste them as Net Labels and Wires as shown in the example below.

Sheet Entries are copied and then transformed into Net Labels and Wires using the Smart Paste feature.

You also have complete control over which of the objects in the selection set you want to smart paste. Disable checkboxes to ignore specific object kinds when you Smart Paste your selection.

Another handy feature is the ability to paste the selected circuitry as a graphic. Using this you can easily include a graphic of section of circuit on another sheet, and size it as required. Select Edit » Smart Paste to transform the clipboard objects as you paste them.

On-sheet Text Editing

Text strings can be edited directly on the schematic sheet. Click once to select a text string, text frame or note, then click a second time to edit the string directly on the schematic sheet (or press the F2 shortcut key). This behavior can be disabled by turning off the Enable In-place Editing option in the General tab under the Schematic folder in the Preferences dialog.

Annotation and Re-Annotation

There are three approaches to annotating your design in Altium Designer: Schematic Level Annotation, Board Level Annotation and PCB Annotation.

The Schematic Level Annotation feature allows you to match components by parameters, Reset All or Reset Duplicate Designators, Back Annotate from your PCB document back to your Schematics and set Designator Index Control and Suffix Options for Schematic Sheets.

In the Schematic Editor, use the Tools » Annotate Schematics command to open the Annotate dialog, where you can reassign the designators for all or selected parts in selected sheets of the current project, so that they are unique and in consecutive order.
Press F1 when the Annotate dialog is open for more information about this process.

You can also use the Tools » Annotate Schematics Quietly command to assign a unique designator to any component that is currently undesignated without launching the Annotate dialog. This command obeys the Schematic Annotation Configuration you have previously set up in the Annotate dialog. Annotate Schematics Quietly does not assign unique designators for duplicates.

The Tools » Reset Schematic Designators command can be used to reset all component designators in the active project, or you can choose to reset only duplicate designators (Tools » Reset Duplicate Schematic Designators).

To re-annotate all component designators in accordance with the Schematic Annotation Configuration defined in the Annotate dialog, use the Tools » Force Annotate All Schematics command.

Back Annotating (Tools » Back Annotate Schematics) will update the designators of the components in the source schematic sheets of the active project, using a WAS-IS file generated when re-annotating designators in the PCB document.

Board Level Annotation is the process of annotating compiled components (the physical view of your components) through the Schematic Editor. Use the Tools » Board Level Annotate command to open the Board Level Annotate dialog, where you can calculate naming conventions of your compiled components based on Naming Schemes, Back Annotate from PCB documents to Compiled Documents, specify custom names and Reset All Designators.

The Board Level Annotation Dialog allows you to customize your Naming Schemes through the Annotate Options, Reset All Designators or create custom names for your components.
In the PCB Editor, use the **Tools » Re-Annotate** command to open the **Positional Re-Annotate** dialog, where you can reassign the designators positionally. Each Re-annotation process produces a unique *.WAS file that carries the date and time in its filename. This file is used when you perform a Back Annotation during either a Schematic Level or Board Level Annotation.

For more information about annotating your design, see the *Understanding Design Annotation* Application Note.

### Editing an Object’s Properties

To view or edit the properties of any object, open its associated *Properties* dialog in one of the following ways:

- When an object is ‘floating’ on the cursor during the placement procedure, press the **TAB** key to open its *Properties* dialog.
- Double-click on a placed object to open its properties dialog directly
- Select **Edit » Change** from the menu to enter the object change mode. Click on the object that you want to edit. Right-click or press **ESC** to exit object change mode
- Click on a placed object to select it, then edit its properties in the **SCH Inspector** or **SCH List** panel, as described below.

### Editing Vertices from the Properties Dialog

You can edit the co-ordinates of vertices for bus, wire, polyline and polygon objects via the **Vertices** tab of their *Properties* dialog. For example, the **Wire** properties dialog has a **Vertices** tab, from where you can edit the individual vertices of the currently selected wire object as required.

The main region of the tab lists all of the vertex points currently defined for the wire. You can add new vertices to the wire, edit the coordinates of existing vertices, or remove selected vertices altogether.

Click the **Menu** button or right-click within the main list region to access a pop-up menu from where you can edit, add or remove vertices or copy, paste, select or move cells. The **Move Wire By XY** command will move the entire wire object. The **Move Wire By** dialog will appear, from where you can enter the increment value to be applied to each vertex point's X and Y coordinates.
Editing Objects in the SCH Inspector Panel

The **SCH Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the current or open document(s). When used in conjunction with the **SCH Filter** panel (F12) or the **Find Similar Objects** command (Shift+F), or right-click on a selected object and choose **Find Similar Objects**), you can make changes to multiple objects of the same kind.

Select one or more objects and press F11 to display the **SCH Inspector** panel or click on the **SCH Inspector** tab. If the panel is not visible, click on the **SCH** button in the Status bar and select **SCH Inspector**, or select **View » Workspace Panels » SCH » SCH Inspector**. You can also set the **Double Click Runs Inspector** option in the **Graphical Editing** tab under the **Schematic** folder in the **Preferences** dialog, which brings up the **SCH Inspector** panel instead of the object’s **Properties** dialog when you double-click on a design object.

Note that the **SCH Inspector** panel only shows properties that are common to all selected objects. The attributes listed can be modified in the **SCH Inspector** panel. Type in a new attribute, click on a check box or select from a drop-down list where applicable. Press **Enter** or click on another cell in the panel to implement the change.

For more information about editing multiple objects, see the *Editing Multiple Objects* tutorial.

Editing Objects in the SCH List Panel

Select an object (or objects) and press Shift+F12 to display the **SCH List** panel. When used in conjunction with the **SCH Filter** panel (F12) or the **Find Similar Objects** command (Shift+F), you can target and edit multiple design objects. From the **SCH List** panel you can change the properties of the object by selecting **Edit** from the View/Edit drop-down menu at the top of the panel.

Double-click on the object in the Object Kind list of the **SCH List** panel to display its Properties dialog.
## Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Version No.</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>05-Jan-2004</td>
<td>1.0</td>
<td>New product release</td>
</tr>
<tr>
<td>24-Mar-2005</td>
<td>2.0</td>
<td>Renamed from <em>Object Placement and Editing</em>. Concentrates on Schematic Editor objects only in Altium SP3.</td>
</tr>
<tr>
<td>29-Nov-2005</td>
<td>2.1</td>
<td>Updated for Altium Designer 6</td>
</tr>
<tr>
<td>3-Oct-2007</td>
<td>2.2</td>
<td>Updated for Altium Designer 6.8</td>
</tr>
<tr>
<td>16-Mar-2011</td>
<td>-</td>
<td>Updated template.</td>
</tr>
</tbody>
</table>

Software, hardware, documentation and related materials:

Copyright © 2011 Altium Limited.

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or posted on any network computer or broadcast in any media, and (2) no modifications of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment.

Altium, Altium Designer, Board Insight, DXP, Innovation Station, LiveDesign, NanoBoard, NanoTalk, OpenBus, P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to the same are claimed.